#1
I've had this problem on other forums, too.  There's only one forum that I've never had a problem with, and they are the only ones who allow direct copy and paste of images.

When I post photos, I use the Google Photos website on my laptop (Chrombook) or my Desktop (Windows).  I right click the image, select "Copy Image Address", and that's what I paste into the URL box in the insert image URL box in the post editor.  I can see them fine on my Chromebook, Android phone, and Windows Desktop, all via the Chrome browser.  It looks like where things break is with other browsers.

Has anyone figured out an easy way to insert pictures directly from Google Photos that works across browsers?
Garrett - Christian, Husband, Father, Writer, Head Shaver
“Nature has given us two ears, two eyes, and but one tongue-to the end that we should hear and see more than we speak.”
#2

Super Moderator
San Diego, Cal., USA
(This post was last modified: 06-20-2020, 08:30 PM by Freddy. Edited 1 time in total.)
(06-19-2020, 09:51 PM)gwsmallwood Wrote: I've had this problem on other forums, too.  There's only one forum that I've never had a problem with, and they are the only ones who allow direct copy and paste of images.

When I post photos, I use the Google Photos website on my laptop (Chrombook) or my Desktop (Windows).  I right click the image, select "Copy Image Address", and that's what I paste into the URL box in the insert image URL box in the post editor.  I can see them fine on my Chromebook, Android phone, and Windows Desktop, all via the Chrome browser.  It looks like where things break is with other browsers.

Has anyone figured out an easy way to insert pictures directly from Google Photos that works across browsers?

I use Firefox on an iMac so when I saw your post here, I switched over to Chrome and got this:

[Image: Burnzhy.png]

I do have an LG phone running Android but, it too, did not display the photo (nor did Safari on my iMac but I didn't expect it to after what you have described here).

My photos go to "Photos", Apple's answer to Google Photos.  However, I also have Google Photos.  When I suggested you try Imgur (which is added to DFS and one doesn't have to make an account there to use it here), I tried to put one of my photos from Google Photos on my desktop to be able to get it into a post.  However, the photo does not show as a jpeg; it has to be converted before it shows on DFS.  I wonder if that is the problem and if there is a simple fix.  andrewjs18 is our tech person and he may know how to fix this.  Also, like you, he does not use Macs regularly so may have a better handle on the problem.
#3
(This post was last modified: 06-20-2020, 07:06 PM by gwsmallwood. Edited 1 time in total.)
Dave gave me a workaround that is acceptable, though it only works on my Chromebook or Android phone, not on my Windows machine.  If I'm on one of those devices I can use the "Upload to Imagur" option and select the appropriate edited version of the photo from Google Photos, instead of the raw image from my camera roll.  On Windows, there's no longer any way to access your photos through your Google Drive sync folders, so it doesn't work there.
Garrett - Christian, Husband, Father, Writer, Head Shaver
“Nature has given us two ears, two eyes, and but one tongue-to the end that we should hear and see more than we speak.”
#4

Administrator
Philadelphia, PA
it might be a google permission issue with the photo or maybe they do not allow hot linking, I am not sure.

you may also need to use the direct link to the image between image tags too. can you post a link (don't wrap it in img tags) to a google photo in here for me to try?
Tu ne cede malis, sed contra audentior ito.
#5
This is the way I was trying to post them before.

[Image: lpUWNzkgQRDpLKsS1FuUoMKtX7iO2qtf7d09fg4f...authuser=0]
Garrett - Christian, Husband, Father, Writer, Head Shaver
“Nature has given us two ears, two eyes, and but one tongue-to the end that we should hear and see more than we speak.”
#6

Administrator
Philadelphia, PA
(06-22-2020, 02:48 PM)gwsmallwood Wrote: This is the way I was trying to post them before.

[Image: lpUWNzkgQRDpLKsS1FuUoMKtX7iO2qtf7d09fg4f...authuser=0]

yeah, if you copy/paste that url into the browser, it wants you to sign into google.

can you send me a link to an album you're wanting to use a picture from, just so I can test?
Tu ne cede malis, sed contra audentior ito.
#7
I'm not trying to share an entire album, just individual pictures. It's really a google issue. Unless you're on an android device, there's no way to use Google Photos like a network drive. You have to download things from Google Photos to your local machine, then you can upload them to different sites. It's a pain, lots of people have complained about it since they removed the Google Drive integration, but so far, Google hasn't done anything about it.
Garrett - Christian, Husband, Father, Writer, Head Shaver
“Nature has given us two ears, two eyes, and but one tongue-to the end that we should hear and see more than we speak.”
#8

Member
Indiana
From what I've read, you can only link to photos in a shared album and then only if you copy the photo url while not logged in (e.g. using a different browser). Haven't tried it myself, though.


Users browsing this thread: 1 Guest(s)